WordPress手动更新最新版本 附临时终极解决方案

很多博主会遇到有新版本的Wordpress发布时,更新失败的现象,虽然现在有很多解决教程,我在这也再次发布一遍。

现在又有新版本4.9发布了

WordPress手动更新

 

后台点击更新,

显示“另一更新正在进行”

WordPress手动更新

 

hhh,没遇见过,去群里问一下大佬,大佬告诉的答案是

1、在当前WP程序的wp_options数据表中;

2、找到core_updater.lock字段后删除再重新点击后台自动升级链接。

开始更新了,

  • 先备份了一下网站和数据库(防止手抖失误。。)
  • 然后进入数据库,在wp_options表下的最底端删除core-updater.lock记录  (这是更新失败后对多出来的,还是删除比较好)
  • 然后在WordPress官网下载最新版本的安装包
    • WordPress官网
  • 下载后解压,删除里面的wp-content文件夹(这个必须删除,因为网站上面的素材全都保存在这个文件夹里)
  • 重新压缩其余的文件,上传到博客网站根目录
  • 删除网站原来的wp-includeswp-admin两个文件夹
  • 然后解压覆盖原来的文件
  • 替换完毕后,访问https://你的网站域名/wp-admin/upgrade.php
  • 看到如图显示就说明更新成功了!

WordPress更新

  • 再次进入后台看看是否显示已经是最新版本了!

更新成功

 

下次再遇到这种情况操作就更快速啦!


其实出现这些问题归根结底就是 WordPress 默认的自动更新调用请求的downloads.wordpress.org服务器是在国外造成的,在国内自动升级wordpress的话会非常慢甚至超时失败。某位站长在国外服务器架设了一台代理服务器,可以直接拿来用,由于代理服务器限制了只能代理wordpress.org域名,使用完后请注释掉代码,以免影响wordpress使用。

  • 解决方法

打开网站根目录的wp-config.php,在底部增加如下代码:

define('WP_PROXY_HOST', 'us.centos.bz');
define('WP_PROXY_PORT', '31281');

保存之后登录wordpress后台,切换到更新,点击升级按钮开始更新。

更新完成后请注释掉刚才加的代码,即在前面添加//,如:

//define('WP_PROXY_HOST', 'us.centos.bz');
//define('WP_PROXY_PORT', '31281');

下次需要升级时再删除注释。

使用这个代理后,马上就可以在 WordPress 后台里正常的更新 WordPress 到4.9版了,可以说是个很好的解决 WordPress 更新故障的好办法,就是大家一定要记得更新完成后要注释掉哦,要不会影响到 WordPress 的正常使用的,这个代理就是 WordPress 更新失败是的一个临时终极解决方案而已。

3 条评论

发表评论

*